Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dosing Pump Setup
#1
Okay, I've picked up some of these (https://www.amazon.com/Kamoer-Peristalti...s_li_ss_tl).  Trying to get the first one set up is proving less than intuitive.
It's wired to DC1 on the Lighting & DC Module.

That module is connected to a 12v power source, has a jumper across the DC1 Float, and is connected via CAT6 to the DC Ports and LED Ports  on the main controller.

In Reef-pi Drivers, I have the PCA9685 driver loaded as 'Extra Ports'.
In Connectors, I have a Outlet configured (name DC1) utilizing the 'Extra Ports' driver and Port 1.
Under Equipment, I have 'DC-1 Doser' set up using Outlet 1.

I have also tried:
Connecting the pump to DC4 (and moved the jumper to DC4 Fload).

In Connectors, I have a Jack ('DC4') that uses the 'Extra Ports' driver and Pin 4 (active low).
Under Dosers, I have Pump-1, Volume 10 (I was trying a random non-zero value), Type DC Motor, Jack DC4, Pin 4, Status Enabled, Duration 10, Speed 100.
(Note, after finding https://docs.google.com/document/d/1Vko1...=h.2jxsxqh, I also tried Pin 12)

Plugged into the respective port, I can't get the motor to turn on by either enabling the outlet or running the Calibrate function for 10sec/100%.

Some guidance please?
Reply to top
#2
Hi Blake, sorry it's giving you troubles, sounds like you are doing everything correctly. This one line causes questions but maybe it's just the terminology. 

Quote:Under Equipment, I have 'DC-1 Doser' set up using Outlet 1.

You mentioned the DC1 connector is named "DC1" which sounds right if you used my install script however above you mentioned you used "Outlet 1" on the equipment tab. Outlet 1 should be for the power bar, you should see "DC1" in the drop down when you configure the equipment.

With that said your test using DC4 all sounds good, I think it should have worked.

Can you run the following command in the SSH terminal?

i2cdetect -y 1

That should print a table of addresses, you should see 40 and 70 for the extra ports driver.

Does the pH work? If you aren't using it can you add it to the pH tab and see if you get any values? You don't need a probe connected to test it.

And for reference the manual you are looking at is for a different version controller, these ones are for yours.

https://docs.google.com/document/d/157ep...1RZr1/edit

https://docs.google.com/document/d/1dxnP...urt36/edit
Reply to top
#3
I see 40 and 70.  I also have 63 and 68.  How do I tell which address the Extra Ports / PCA9685 driver should be using?

Yes, pH is working AFAIK.  I have the probe attached, but it's still sitting in the storage solution it shipped in (as I know not to let it dry out).  I have it utilizing address 99 (based on some posts/documentation I found here somewhere), and it's been getting slight variations in reading.  I assumed it was from me jostling it around my desk and the probe ending up more or less in the solution.  Detaching the probe for a while, the reading jumps from ~4 to ~12+.  So, yeah, I believe it's working.

Nevermind.  I got it working.  Address 63 worked with the DC4 config.
Reply to top
#4
Okay, what'd I screw up now?

I was troubleshooting the pH probe periodically reading 0.  Unplugged everything, installed a 10k resistor on the probe port, plugged everything else back in.  Still had the issue.  Added dtparam=i2c_arm_baudrate=10000 to the /boot/config.txt and rebooted.  (That seems to have fixed that.)  So, I shut down again, removed the resistor and reinstalled the probe.  Powered up.

pH is reading just fine.  BUT, I have two errors.  One on the dashboard and one in the error log:
{"error":"stats for id: '3' not found"} | HTTP 404 appears on the dashboard

And this in the error log:
May 18 11:24:21        failed to initialize driver: Extra Ports Error: remote I/O error


And the dosing pumps are back to not working...  ARGH. :P
Reply to top
#5
Oh no, sorry to see this, we will get there.

Address 63 is for the pH circuit, that's a hex value 0x63 so in reef-pi it's 99 on the pH driver.

Address 68 is for the real time clock, you can ignore that one.

Address 40 and 70 are for the "extra ports" which is that error, in reef-pi the driver for extra ports uses 64 (0x40).

The error on the dashboard is likely related to pH, if you delete pH from pH tab you need to delete the chart on the home page first.

Try 3 commands below in the SSH terminal, this will reset everything. After it goes through the install again for the DC port you should be able to add each port directly to "equipment" tab (if connector is an outlet) or "dosing" tab (if connector is a jack).  Any time you make some changes it's a good idea to go to the "configuration" tab and then the "admin" sub-tab and press the "reload" button. When it asks which Robo-Tank controller you have select v3.

wget -c https://www.robo-tank.ca/reef-pi_install_files.zip


unzip reef-pi_install_files.zip

sudo bash reef-pi_install_files/install_reefpi.sh
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  PWM Setup plecosam 5 1,725 04-12-2023, 08:46 PM
Last Post: Rob F
  PWM setup help Supernova 3 2,016 09-26-2021, 09:07 AM
Last Post: Rob F
  Anybody having trouble with dosing pumps module? JFReyes 8 5,390 03-06-2021, 07:07 PM
Last Post: JFReyes
  Issue with getting ReefPi Dev Environment setup Correctly kfialkowski 4 3,161 11-09-2020, 01:30 PM
Last Post: JFReyes

Forum Jump:

Current time: 03-01-2024, 02:01 AM