Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Origninal Robo-Tank problem
#1
Hi Rob, Hope you are well.

I'm having a bit of a problem with my Robo-Tank,  It was in use for ages on the hospital/quarantine tank then I shut it down for a while as it was not required.
The plan was always to install it on my main tank but the logistics meant it never happened, recently I decided to upgrade the main tank for a bigger and better one in a different location, that meant I could set the tank up and get it running with no panicking about swapping things over.
So out came Robo-Tank still running the v5.02 it was on, a new better all in one power box/power supply unit was built to be integrated into the tank (well the tank was designed around it) it was tested for a week just running a water butt with heaters and pumps, had a few niggles with temp sensors giving weird readings causing the heaters to keep coming on but set it to use a different port and it was fine.

All the main tank work and installation was done last weekend and the tank was filled and fired up, all seemed fine, the temp sensors were more stable but the schedules wouldn't work, if I pressed resume all the outlets turned off, the plan was to test it all for a while anyway so didn't really worry too much and just turned the pumps to manual, a few days ago I did the reset on the controller and the schedules came back, great all working, today they had stopped working again so decided to update the software to v5.20.

Did the update as per the instructions, all completed ok but when it started up power bars and DC ports were working INVERTED, green on the icon was off, heaters were ON when the temp was reached and off if it was below.
Tried to see if there was a setting but nothing, needed to get the tank going again ASAP (its ready for the fish) so ended up putting v5.13 on, that has worked but now getting one or two temp sensors jumping about again.
Any ideas on what could be the problems, 1 with the inverted power bars and 2 with the temp readings (did try new sensors)

Sorry to see the original Robo-Tank is gone, I did have Reef Pi running for a while and was going to use it BUT found Robo-Tank and decided to get that instead, mainly because it had the local touch screen, I found the Reef Pi web only interface very frustrating to use.

Just as a thought, do you still have any of the original Robo-Tank display and controller boards available as spares?

Rob
Reply to top
#2
Hey Rob, sorry to hear about the problem, unfortunately there are some scheduling issues in v5.x. Sometimes when they're added all the data doesn't make it to controller so display shows them but they don't work. Usually a "sync" on system page will fix that.

I'm a little surprised about the temp sensors, that hasn't been a problem. What kind of readings are you getting? If the probe is left out of the tank does it work ok?

There is a setting hidden for the inverted outlets, if you go to settings, hardware, equipment connected, addons, select the power bar and there's a setting for power bar version, change that, restart and it should be ok.

If you still have problems it might be better to go back to v4.2 as that's pretty stable but if this is all the problems you should be ok with 5.2, that's what I run with no issues.

Sadly I messed up with v5 and overall was going in the wrong direction, even though I love the setup people want to use their phones. The cost was high and doing everything was really too much to handle so I decided to park it but I'm itching to take a new approach.

I don't have any extra boards, if you have any problems I can direct you to what parts would be needed.
Reply to top
#3
Hi Rob, thanks for the reply.
Will have a go with v5.20 and that setting when the tank has been running a while, I just transferred the fish over today and de commissioned the old tank today so will give them a while to settle in. The schedules are working ok at the moment.
The temp readings on 2 of the sensors (I have 3 on the tank, sump in, sump out and one in the tank) are jumping up and down by about 1 deg C and also showing HI max readings of 60 deg C, one seems pretty stable (the one I have set to control the heaters) but the heaters (3x 300w) are all coming on at once not stages as they are set up (1st at 25.7, 2nd at 25.4 and 3rd at 25.1 so it generally uses only 1 heater unless that can't cope) and even if the tank sensor is at 26 deg C
The temp/humidity is totally fine!
I will try different sensors over the next few days and see what they do.
Regarding flow sensors I have a 10000 lph pump on the tank yet the highest the flow will read is 1400 lph when set at 1.0 hz, if I set it at 4.5hz (F=4.5 * Q (L / Min) or 270 pulses/litre) it reads about 350lph.
The flow sensor I have should be able to read up to 7500lph which would be about what I should have (some to the reactor and some to the fuge plus the pipework restrictions)

Are there any plans to be able to use a maybe 7 inch hdmi touch screen display on your new Reef-Pi at all, that would be much easier than having to use a phone or computer?
Reply to top
#4
Sounds good. The one degree change seems to be something like a stray voltage issue, it shouldn't jump more than 0.2 c/f. Often it will jump .2 because of rounding, the readings have a minimum spacing of .11 so if sitting at 25.44 (25.4) and it goes up it'll be 25.55 (25.6). Can you try running a ground wire from the tank water to ground on your AC outlet.

The max reading of 60 could be may things and I never got to add something to discard any odd readings. A reading like that should only happen once and a while, sometimes I see 18.3 on mine. It will turn the heater off but the next reading will turn it back on if it should be, the real problem is it messes up the min/max and graph.

As for the flow did you set the hz to less than 1.0? Did you try the auto calibrate? Estimate how long it takes to pump what you set the water volume to and use the start/stop timer buttons to enter the time in.

reef-pi isn't mine, I'm only making hardware for it so I can't really answer that. It has the ability to operate with a Pi display but sounds like it has issues, one day I'm going to get one so I know. I read some people dedicate a tablet and set it up in Kiosk mode but I haven't tried it.
Reply to top
#5
I have ordered a 316 stainless rod as its marine grade, will add that as a ground into the sump and see how it goes.
I can't set the flow meter to below 1.0Hz, also tried the auto calibration set the volume to 33 litres and timed it for 20 seconds, flow rate came out at 400 ish LPH, even tried going extreme and trying 20L in 2 seconds that was 130LPH !! weird.
Reply to top
#6
Sounds good, let me know how it goes.

Now I remember someone else had the same issue, I made some changes so it could go below 1.0 and there could have been another math related issue. I'll send you some sketches to try.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  After installation from 4,2 to 5,13 problem vilich 22 2,531 06-18-2019, 10:29 AM
Last Post: vilich
  Forum Profile Problem Gordon Lehmann 3 1,088 03-06-2019, 02:55 PM
Last Post: Rob F
  Display Problem simonv92 12 2,097 03-04-2019, 09:54 AM
Last Post: Rob F
  Problem with the controller when the electric current is stopped. vilich 6 2,379 04-23-2018, 04:57 PM
Last Post: rott

Forum Jump:

Current time: 09-24-2020, 04:25 AM