Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Putty SSH login problems
#1
Hi, trying to setup my Pi via SSH but it doesn't recognize the password I setup when installing the OS. I logged into my router to get the IP address for the Pi so I assume that's correct. Trying to login to port 22. 
Tried "pi" and "Pi" as the login.
I tried the default password.
Tried running Putty as an administrator.
Not sure what I'm doing wrong. My password was generated by Last pass and has characters, numbers, etc. Maybe that's the problem?
Any help is appreciated.
Reply to top
#2
Hi Greg, sorry it's being difficult, currently I'm not sure what the issue is, port 22 is correct. As you see the IP address I don't think it has anything to do with your network.

When you installed the OS did you use this manual?

https://docs.google.com/document/d/1t9ma...o3woZ/edit
Reply to top
#3
Just got it. The raspbian installer auto filled the username so it wasn't pi anymore it was ewanc. It autodetected my network SSID as well. Maybe a new feature?

anyways I think reef pi is installed now. Just going to restart and login
Reply to top
#4
Right on. The SSID auto detection sounds handy, I've never experienced that, probably a new feature. I'm using Pi Imager 1.7.3 but when I open it tells me there's an update.
[-] The following 1 user Likes Rob F's post:
  • Greg Ewanchuk
Reply to top
#5
I can access reef pi now. Thanks Rob.
Is there a certain order of progression to follow now? I'm guessing I install the Robo tank app and start setting equipment up.
I'd like to setup remote access so I can view parameters while on vacation. Would that be done after the robo tank app is installed or does it really matter?
Reply to top
#6
Great! For reef-pi the drivers and connectors were added during install so it's just a matter of adding things to equipment tab, ATO, temps, dosing etc.

For remote access the easiest and safest method is to use a program like TeamViewer to remotely connect to a computer on your network. You can do things such as port forwarding however if you are unsure about it that can cause security issues with your network so only do that if you really understand it.

My app is independent from reef-pi, you can't install both on the same SD card as they use different web servers. If you want to test it out it's best to use a 2nd SD card and you can swap back and forth easier. My app is still in beta testing and I'm happy with the reliability, just be sure to test things and monitor as it's possible you adjust a setting to something I wasn't expecting and causes it not to work. If it runs as it should after setting up it'll be ok. It's 50/50 you get a problem during installation such as a black screen or can't log in, if that happens here's a post explaining the steps to get it working.

https://www.robo-tank.ca/forum/thread-17...ml#pid8459
Reply to top
#7
Thanks Rob, as I was installing the Robo tank app it clicked in my mind that it probably can't be loaded with Reef Pi already on the card. I just started over and will start with Reef Pi for now. I managed to setup email alerts so I'm pretty happy with myself. I'll try the Team viewer. That sounds right up my alley.

Thanks again!!
Reply to top
#8
No problem and sounds like a good plan. Once you get familiarized you can explore more.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  Heater problems adammac1 5 2,042 10-08-2022, 12:10 AM
Last Post: Rob F

Forum Jump:

Current time: 03-01-2024, 12:46 AM