Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Temp sensors acting weird
#1
Hi Rob,

When I upgraded to 5.2 from 4.something, two of my 3 DS18B20 temp sensors were jumping around wildly, in the 200+ degree range. The third one is acting fine. I figured they had failed, so I ordered a couple new ones, however the new ones that arrived today are doing the same thing (3 separate sensors on port 9). 
I tried calibrating it but obviously won't change that much. 
I have the heater set, so when I connect a sensor, the relay for the heater clicks on and off every 5 to 6 seconds, so I'm thinking the temperature is fluctuating and being registered by the display enough to change the heater, but not registering on the display.
Actually, as I type, I remember that at first, it would register a normal temp on the display, say around 82 or so, then jump to over 100-200, then back. 

I haven't yet swapped the working sensor into the funky port yet, I'll try that and see if the fault follows the sensor or the port.

They are all the plastic tipped waterproof sensors from Sparkfun if that makes any difference. 

Sorry for the poor explanation!

Any ideas?

Thanks!
Reply to top
#2
Hi Skwerl77, how many ports are doing this, is it two? Did you try the other ports?

Can you go to settings, system and press "sync" button, this will copy all settings from display to controller so we can rule out a setting.

Can you also try moving the heater sensor to a different port and change the port on the heater settings page to match.
Reply to top
#3
So out of the 4 ports I use for temps, it's doing it on 2 of them, ports 9 and 12, the display and the sump. Both are DS18B20's.

If I change the port setting on the heater page to one of the other two working sensors (my LED lights - port 11, DS18B20 or sump air temp - port 10, DHT22), the heaters act accordingly depending on the sensors respective temps.

The sync didn't appear to make any difference.

A new weird thing I noticed, is when I left it on the sensors page so I could better see the temps, when the new DS18B20 was connected to port 9, port 1 would change back and forth intermittently. (I use port 1 as a display high float that shuts off my return pump so I don't flood the place if something gets backed up.) I verified that manually tripping the float does activate the rule shutting off the return pump and skimmer like it's supposed to, but the screen shows the state going back and forth open and closed every 2 to 15 seconds with a seemingly random timing, sometimes 30 to 40 seconds with no change, and it does not activate the rule when this happens, only when I manually flip it.
Reply to top
#4
That new issue you just discovered is related. It appears the incoming sensor data isn't always going where it should. It's possible the sync didn't fix it as the issue could be on the display. Try the following.

Go to settings, hardware, equipment connected and make sure all boxes are checked. Before leaving this page cycle each setting as in uncheck and recheck. After it restarts then go to settings, hardware, temp settings and cycle each of the options for the 5 ports. Then restart again and hopefully it's fixed.

If this doesn't work, sorry to ask so many times, but what Rev version of controller board do you have?
Reply to top
#5
No luck with the hardware settings and restarts. Actually now it seems like my homescreen customization has changed.. Like where the pH used to be, it's now the ATO float, and the LED temp and Sump air temp isn't scrolling at all (nothing is). Not a big deal, just might be relevant?
The sump temp is still jumping around to 243.4, 124.6, 225.4, 218.2, 135.4, 193.0, 77.8 (probably what changes the heater state), 217.3, 128.3.. Actually, it's those exact temps, always. Some more common than others, but it's always those. Maybe they'll change over time? And port 1 is still flip flopping.

I don't know which version board it is, it was one of the first of the new style. It's orange if that helps? If it's really important, let me know and I'll have to disconnect a bunch of stuff and dig it out of where it's mounted.

And now (maybe always I'm just now noticing?) on the sensors page the CO2 sensor (that I don't have, nothing should be connected to that?) is labeled pH Probe and it has a fluctuating reading between 17.88 and 18.02-ish. The only probe I do have is a pH probe, and that is also giving a reading and also labeled pH Probe.

The min and max on port 12 is 41.0 and 250.6, so disregard the exact temps line above..
Reply to top
#6
I would have guessed the invalid readings were all the same, that makes sense. Also the home screen would change like it did, when you change the hardware ports those are reset so you need to set that up again. The controller board is ok, thought maybe it was an early Gen2. I hate to do it but I think you have to do the restore defaults and setup again, that should fix it.
Reply to top
#7
Okay so first my apologies. I moved the one working DS18B20 from port 11 to port 9, and it displayed the correct temp. So port 9 is okay.
I connected the brand new sensor to port 11 and it did the weird thing. Tried the other brand new sensor, and same thing. So 2 bad brand new sensors.
Put the original sensor from port 11 back to port 11 and it worked fine. Should have just done that from the start, should have known better.

I have some raw DS18B20's at work that I've been meaning to attach wires to and pot, guess I'll do that tomorrow. Right after I write a sternly worded email to sparkfun, however.

I think I'll do the restore defaults anyway and start fresh tomorrow. Thank you for your help! I'll let you know if everything is working tomorrow.
Reply to top
#8
This sounds a little better. Let me know how it goes with the other sensors, sorry for messing up all your settings in the meantime. :)
Reply to top


Possibly Related Threads...
Thread Author Replies Views Last Post
  Temp Cable Length aquaalgae 1 656 07-25-2018, 04:55 PM
Last Post: Rob F
  temp sensor 1/2/3/4 Addi 1 1,382 06-09-2016, 01:19 PM
Last Post: Rob F
  temp precision and hysteresis in C° mode oco89 6 3,560 03-22-2016, 08:44 AM
Last Post: Rob F

Forum Jump:

Current time: 10-20-2019, 11:15 PM