Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TFT01-7.0 calibration not working
#1
Tongue 
Hi Rob

My 2nd kit with the touch screen TFT01 7 inch elecfreaks is not calibrating for some reasons

I have make sure it is UTFT myGLCD(TFT01_70, 25, 26, 27, 28);  // used for ElecFreaks and Sainsmart 7" Display and also using the proper Utouch library file

It will display but i can touch anything as on settings bring power instead etc 

I did try this also UTFT myGLCD(CTE70, 25, 26, 27, 28);  // Sainsmart 7" Display and same result .  K05106
Reply to top
#2
Hi Fred, you want to use the first bit of code as you did. Try closing the Arduino IDE, in the download package go to the calibration folder and copy the uTouchCD.h file in the the ElecFreaks display folder. Paste that file in the your documents/arduino/libraires/uTouch/ folder and overwrite the existing file. Then open the sketch again and upload it. If that doesn't work and your other controller uses the same screen plug this screen into that controller to see if it works. If both displays are the same you won't need to change anything on the working controller. If it doesn't work on it then it sounds like the display is bad.
Reply to top
#3
(06-15-2016, 06:23 PM)Rob F Wrote: Hi Fred, you want to use the first bit of code as you did. Try closing the Arduino IDE, in the download package go to the calibration folder and copy the uTouchCD.h file in the the ElecFreaks display folder. Paste that file in the your documents/arduino/libraires/uTouch/ folder and overwrite the existing file. Then open the sketch again and upload it. If that doesn't work and your other controller uses the same screen plug this screen into that controller to see if it works. If both displays are the same you won't need to change anything on the working controller. If it doesn't work on it then it sounds like the display is bad.

All good now. The issue was,  i didn't close and reopen Arduino when overwriting the libraries
Reply to top
#4
Ah nice, I've done that before.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  ato not working lumpylipton 27 7,052 08-05-2018, 08:17 PM
Last Post: Rob F
  Got v1.6 Robo-Tank Close to Working sonicmach1 17 5,885 02-16-2016, 07:14 AM
Last Post: daveabbott007

Forum Jump:

Current time: 11-26-2020, 12:04 PM