Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Screen issues.
#1
Ok so a few of us have been having issues with screens.

Most seem to be the miss selection of the correct screen type in the display code (lines 48-50) or a library issue.

However as always I have to be different.
After some library issues I was getting the screen part working sometimes. I then noticed some of the header pins hadn't taken much solder (that's what you get for soldering at 06:00 after 4 hours sleep, I work nights and my sleep patterns are all over the shop, sometimes I just can't sleep), So I have gone back over the headers I could see that didn't seem to have much solder and amazingly the Robo-Tank splash screen worked and I got this.
[Image: WP_20160216_007_zpsp8htmm5m.jpg]
No touch working currently (I think I still have some library issues).
I've noticed a few things. The feed display, I've seen this with my current arduino based controller when you pull the RTC, the date and time display 255 etc. I'm sure at one point the date and time was also the same, but it seems unset (as you'd expect after first power up) today when I've powered up.
Then after 40 seconds or so this happens.
[Image: WP_20160216_010_zps3jhef63m.jpg]
This happens anywhere from as soon as it starts to power up during the splash screen to 40 seconds after power up. It starts as a square here a square there and after a few seconds the screen is full up.
Now I'm not sure if this is happening because I'm disturbing something loose when tapping the screen to see if there is any responce or if it's a component that's getting to hot and overheating for instance.
Rob mentioned powering the display board to bypass the network cable, it does the same thing, if anything lasts longer when powered from the connector board.
This is the setup.
[Image: WP_20160216_008_zpsdkknhaem.jpg]
And the temp sensor seems to work when connected so the boards are talking and reading one wire sensors fine.
[Image: WP_20160216_009_zpsdvzad31e.jpg]
Anyone care to hazard a guess lol.
Reply to top
#2
I think it is an issue with the images used to make all the icons.
is the SD card formatted correctly and are the images loaded on the SD properly?
Reply to top
#3
Yeah I formated to fat 32 and put the images on the card. I might try and reformat and reload the images and see what happens. I'm missing some stuff on the home screen aren't I.
Reply to top
#4
missing some stuff?
you've got some stuff on your screen :P
does the touch work?
Reply to top
#5
No touch, about to start worrying about how I'm going to fix that.

Power status area is empty, should there be something there?

I'm thinking it's a duff screen so I might not press on to hard with fixing the touch issues. I've pined down what makes the screen go static. If I disturb one of the ribbons going from the screen to it's PCB the static happens. I've disconnected and reconnected both ribbons at the PCB but there is no difference.
Reply to top
#6
Benny
when you first installed the IDE it did not install all the libraries and you had to add a bunch of them manually
Reply to top
#7
Yes sorry should have included that at the start of this thread.

I had to manually add all the libraries, I already have the 1.04 IDE for my Jarduino that Robo-Tank will be replacing. I just downloaded the IDE and ran it instead of using the install wizard.
Reply to top
#8
just makes me wonder if that isn't part of the problem that the IDE it self is messed up did you down load the IDE 1.60 non install zip??
(I prefer to have all my working IDE installed)

if not give that a try real fast takes just a minute is he 1.04 installed ?
Reply to top
#9
Yes 1.04 is still installed and if the Jarduino goes tits up like it did the other month I'll need it to reinstall it if my Robo-Tank isn't up and running.

I did have some similar issues with the last project and the IDE not quite right. I think I need to strip the laptop of all the IDE's I have and start fresh with just 1.6 and maybe remove all the Robo-Tank downloads and redownload it from fresh too. This was the solution when I last had issues like this thinking about it. What a pain in the ass. Nevermind, I'll get there.
Reply to top
#10
Hey Benny314, when fietsenrex mentioned the images it brought back memories. Someone else was having this problem and it turned out to be a relay icon image causing the problem. It isn't because you're missing the icons that's an eeprom related issue. I believe he downloaded the images again and re-loaded them and it fixed it, I'm trying to find our conversation but not remembering who it was and tons of emails its not easy. Where on the screen does the pattern begin? On his it was at the icon causing the issue. For sure its not library related, the touch is, that's the hardest to get correct on the sainsmart, imagine that Smile

Here's some different calibration numbers I have that might get the touch working. Open the UTouchCD.h file and paste these over the existing ones. If you have the Arduino IDE open make sure you restart it so it sees the changes.

Code:
#define CAL_X 0x00204F8FUL
#define CAL_Y 0x039FC1B9UL
#define CAL_S 0x8031F1DFUL

Code:
#define CAL_X 0x03A50118UL
#define CAL_Y 0x03C7C0D3UL
#define CAL_S 0x001DF31FUL

Code:
#define CAL_X 0x00248EA8UL
#define CAL_Y 0x00270ECBUL
#define CAL_S 0x8031F1DFUL

The reason the power icons are missing is a setting in the eeprom is correct, I probably forgot to add it to the eeprom defaults, when you get the touch working do the following and they'll show up.

Press "Settings", "Customize", "Outlets" and then exit the screen with the yellow icon and return to the home page and they should appear.
Reply to top
#11
(02-16-2016, 12:26 PM)Benny314 Wrote: Yes 1.04 is still installed and if the Jarduino goes tits up like it did the other month I'll need it to reinstall it if my Robo-Tank isn't up and running.

I did have some similar issues with the last project and the IDE not quite right. I think I need to strip the laptop of all the IDE's I have and start fresh with just 1.6 and maybe remove all the Robo-Tank downloads and redownload it from fresh too. This was the solution when I last had issues like this thinking about it. What a pain in the ass. Nevermind, I'll get there.

I wouldn't worry about your IDE as you are programming them. The touch is UTouch library related. I attached another one to try.

Also a couple times I was messed around because the IDE was still open even though I closed it. I opened the task manager and there was still an instance of arduino.exe running. I closed that from task manager and then it worked.


Attached Files
.zip   UTouch.zip (Size: 864.67 KB / Downloads: 6)
Reply to top
#12
I had a problem like that took me less than an hour to get all the old stuff zipped up and put in a mast zip so I had it all and then I put a text file in with each folder before I zipped explain what IDE it need to have and any special library files then zipped and added with the rest of them like you said shit worked lots better once I got rid off all the different versions I had.

I would keep a copy of every thing or the Jarduino just seems to me Jamie is taking for ever to get version 2 out its been over a year.

where you rom in the UK
Reply to top
#13
Deepest darkest Cornwall.

Thanks for the tips Rob, I'll give them a crack later tonight. It's hard to say where it starts. Some times it's horizontal bars normally working up from the bottom. The squares start to quickly to really pick out where the first one turns up to.
Reply to top
#14
when I go over there it's usually to Manchester and Salford I like going to Dalefort also but the water is just to cold
Reply to top
#15
Here's a simple sketch to try on your display, it loads the splash page and stays on it. See if you get squares with this running.


Attached Files
.zip   Screen_Test.zip (Size: 706 bytes / Downloads: 9)
Reply to top
#16
Hi Rob,

So with the test sketch I don't seem to get the squares.
I've reinstalled the IDE and removed all the old and unrelated arduino from my computer. I'm running the install from C/documents/arduino and I still have the same issues with the fish feeder stating 255 in hours and minutes section and the power status is still empty.
Touch still isn't working either and I've changed the calibration file.
Reply to top
#17
Hi Benny, I expected it would be ok. I would bet your display is fine and the hardware is fine, its something else. I've definitely seen this happen which was an image, I even have a video of it happening in an email somewhere.

The issue with the feeder showing 255 hours and 255 minutes is because those numbers can't grow any larger. Its so far out because your time is set to year 2000. Once you set the clock and do a feed the times will straighten themselves out. The power status section is empty because the eeprom needs to be set by viewing the customize outlets page and exiting.

The main problem we have to solve is the touch so you can get around in the controller.

If the images are loading good then you have the UTFT library working. No need to change anything in that library, its good.

Are you using this line to call the display?
Code:
UTFT myGLCD(TFT01_70, 25, 26, 27, 28);  // used for ElecFreaks and Sainsmart 7" Display

If so change it to
Code:
UTFT myGLCD(CTE70, 25, 26, 27, 28);  // Sainsmart 7" Display

and try and get it working. This how I use to call it until the last time I connected the sainsmart, I discovered it worked with the same as the ElecFreaks but didn't run it long so maybe its best to use CTE70.

So all you need to do is keep playing with the UTouch library and calibration files till you get a match. Every time I've worked with a sainsmart I've had trouble, once I get it working I put all the files together that got it working but next they never seem to work... 

Did you try the different calibration numbers in that UTouchCD.h file in the UTouch library I posted in the thread?

I'm going to try and find mine and give it a go, if I get it working I'll post what I have.
Reply to top
#18
I tested out my Sainsmart and had no issues this time. This is what I did.

  1. Plugged in sainsmart and powered up controller
  2. My touch worked but everything was wrong
  3. Copied the 7" sainsmart calibration file UTouchCD.h into the "Documents/Arduino/Libraries/UTouch/" folder and overwrote the existing file
  4. Open Arduino IDE and uploaded Display sketch
  5. After programming was complete the arduino restarted and showed the home page and the touch worked as it should
I then tried my ElecFreaks screen and the touch was wrong, copied the 7" elecfreaks calibration folder to my UTouch folder and restarted the Arduino IDE and uploaded and that display was working properly.

I then plugged in the SainSmart again and it was wrong, did the same steps as above for it and its working again. So same library should work. I uploaded it again with the correct calibration there. First delete the UTouch library from your documents/arduino/libraries folder and then copy this one there.

If it doesn't work my question is do you get any touch. The touch should always work just not where you expect it to. Run your finger all over the display and something should change. If it doesn't maybe your touch isn't working. My sainsmart the touch only works 75% of the screen which others have experienced.


Attached Files
.zip   UTouch.zip (Size: 865.6 KB / Downloads: 8)
Reply to top
#19
Well I hate to say it but I'm getting those boxes like you, mine takes about 5 minutes to happen. I know its not the hardware because my elecfreaks has never done that and I haven't seen it on any of the CPLD I've been testing, some I've ran for days. Now I have to think it is the display. It happens when something changes on the screen, maybe it gets confused by an image and goes bad from that point.
Reply to top
#20
Cheers for the info Rob.

I'm about to give that library a try. Think this screens touch might be dead to begin with, doesn't matter where I press I get nothing. I'll try and get a new screen ordered up.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  Screen Dimming Tupac 36 14,473 04-04-2016, 02:26 PM
Last Post: Rob F
  Issues loading sketches to Mega and DUE Benny314 9 3,661 02-14-2016, 03:59 AM
Last Post: Benny314

Forum Jump:

Current time: 04-08-2020, 06:19 PM