Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robot-Tank v6.2 can't login
#1
Hi Rob,

Great news on the software, trying to get it installed now

get these errors during install via ssh
Enabling 1-wire
Updating Raspberry Pi Operating System    ...takes 1-20 minutes
Installing i2c-tools                      ...takes less than 1 minute
Installing Apache2                        ...takes about 1 minute
Installing PHP                            ...takes about 1 minute
Installing MySQL                          ...takes about 2 minute
Installing PHPMyAdmin                     ...takes about 2 minute
sed: can't read /usr/share/phpmyadmin/libraries/plugin_interface.lib.php: No such file or directory
Installing Robo-Tank                      ...takes less than 1 minute
Installing Robo-Tank Database             ...takes less than 1 minute
Installing JSON Library                   ...takes less than 1 minute
cp: cannot create regular file '/etc/php/7.3/apache2/php.ini': No such file or directory
Installing MySQL Library                  ...takes less than 1 minute
Installing wiringPi Library               ...takes less than 1 minute
I


Then can't login through address in browser

Have installed raspberry bully if that could be a problem?

tried the following as per previous thread

pi@raspberrypi:~ $ sudo apt install apache2 -y
Reading package lists... Done

Building dependency tree... Done

Reading state information... Done

apache2 is already the newest version (2.4.51-1~deb11u1).

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

pi@raspberrypi:~ $ sudo a2enmod rewrite

Module rewrite already enabled

pi@raspberrypi:~ $ sudo systemctl restart apache2

Job for apache2.service failed because the control process exited with error code.

See "systemctl status apache2.service" and "journalctl -xe" for details.

pi@raspberrypi:~ $ sudo chown -R pi:www-data /var/www/html/
pi@raspberrypi:~ $ sudo chmod -R 770 /var/www/html/



and tried reinstalling Not complete reinstall with reinstalled operating system but just tried installing again and got the same errors

Merry Christmas for Saturday

Cheers

That should be bullseye not bully
[-] The following 1 user Likes Craig's post:
  • Rob F
Reply to top
#2
Hi Craig, well this sucks, the easiest part doesn't work, would sure be nice if I could experience this. Try running the following commands, if you could post what it reports back that would be great.


    sudo apt-get install php libapache2-mod-php -y
    sudo rm /var/www/html/index.html


    sudo apt-get install mariadb-server php-mysql -y    
    sudo /usr/share/debconf/fix_db.pl
    sudo mysql --user=root < /boot/robotank/install/create_database.sql


    sudo sed -i '/if ($options != null && count($options) > 0)/c\if (! is_null($options) && count((array)$options) > 0) {' /usr/share/phpmyadmin/libraries/plugin_interface.lib.php

Merry Christmas
Reply to top
#3
Thanks mate, will try maybe this afternoon, put reef-pi sd card back in to keep things running so need to swap robs-tank back in and will try.

Only thing that could be causing issues is the size of memory card have a 128gb memory card maybe need to go smaller?

Cheers
Reply to top
#4
Sounds good. I don't think it's anything with the SD card, quite a few people have experienced this but I don't know enough yet to determine what it is. Every time I run it on any Pi it works as expected but it's a definite issue. One person got around by reformatting card and installing OS vis the Pi Imager but another that didn't work. Maybe try that, using the Pi Imager then run the script to see if it works. Here's some instructions.

https://docs.google.com/document/d/1fED4...=h.30j0zll

Those commands I posted will try to install php and mysql, I'm hoping one of them gives you an error so I might know what's causing it. It's possible they will say nothing to install and show the latest version installed. If that's the case it looks they installed properly. It seems like something didn't install as it can't find that file it complains about during the install.
Reply to top
#5
Both mariadb-server php-mysql and libapache2 at latest version nothing installed
but this...
sudo /usr/share/debconf/fix_db.pi
sudo: /usr/share/debconf/fix_db.pi: command not found
Reply to top
#6
Thanks, forgot this command, see what it does.

sudo apt-get -y install phpmyadmin
Reply to top
#7
Note if that command does go though the install process it will prompt you twice with a blue screen. First one I think you leave as is and click OK and 2nd prompt go to "No" option and then ok.
Reply to top
#8
Seemed to work, no obvious errors last few lines

Creating config file /etc/phpmyadmin/config-db.php with new version
dbconfig-common: flushing administrative password
apache2_invoke: Enable configuration phpmyadmin
Processing triggers for libapache2-mod-php7.4 (7.4.25-1+deb11u1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
ldconfig: /usr/local/lib/libquickmail.so.0 is not a symbolic link

ldconfig: /usr/local/lib/libquickmaillight.so.0 is not a symbolic link

Processing triggers for man-db (2.9.4-2) ...
Processing triggers for php7.4-cli (7.4.25-1+deb11u1) ...

still comes up with command not found on debconf/fix_db.pi though

no blue screen, I am doing this through ssh
Reply to top
#9
Hmmm, I think the problem is with phpmyadmin as you initially get this error with install script.

sed: can't read /usr/share/phpmyadmin/libraries/plugin_interface.lib.php: No such file or directory

When this installs it prompts as I mentioned which I hate as hard to warn installers so I managed to find some code as follows, this sets something on the Pi, not sure what or where though and stops those prompts. My gut feels it's related.

Code:
echo "mysql-server mysql-server/root_password password robotank" | sudo debconf-set-selections
    echo "mysql-server mysql-server/root_password_again password robotank" | sudo debconf-set-selections
    echo 'phpmyadmin phpmyadmin/dbconfig-install boolean false' | sudo debconf-set-selections
    echo 'phpmyadmin phpmyadmin/app-password-confirm password robotank' | sudo debconf-set-selections
    echo 'phpmyadmin phpmyadmin/mysql/admin-pass password robotank' | sudo debconf-set-selections
    echo 'phpmyadmin phpmyadmin/mysql/app-pass password robotank' | sudo debconf-set-selections
    echo 'phpmyadmin phpmyadmin/reconfigure-webserver multiselect apache2' | sudo debconf-set-selections

I'll make some changes to the install script, I should have it done in next 10-20 minutes. In the meantime maybe reformat that card using the Pi imager I posted earlier then you can run the script I'll post next.

As for as that debconf/fix_db.pi error I'm not sure what it's about or if that command even needs to be run, I think I've seen that error but never removed the command. I saw somewhere it was a good idea to run it as there was a possible issue with the mysql stuff in one of the packages.
Reply to top
#10
I attached the updated install script and removed the code that blocks output to the terminal so you'll see a lot happening this time. I put some line breaks and *********** when it goes to the next install step, try and spot those so you know where in the install it is. The list you posted originally are all the steps. This time you should get those blue screens.

Here's the steps.
  • First run the following two commands.
sudo wget -c https://www.robo-tank.ca/app/releases/Robo-Tank_v6_2.zip

sudo unzip -o Robo-Tank_v6_2.zip -d /boot/
  • Download and extract the zip file attached
  • Copy the install_robotank.sh to the /boot/robotank/ on your SD card and overwrite the existing file.
  • Then run the following command with fingers crossed.
sudo bash /boot/robotank/install_robotank.sh


.zip   install_robotank.zip (Size: 3 KB / Downloads: 38)
Reply to top
#11
newb question how do I copy and install robotank on my sd and overwrite existing file?

or is that done by unzip command

Ignore last comments think I get it I download attached file then copy to sd card overwriting existing file just like you said in your email :P
Reply to top
#12
Yeah those commands will download and create the "/boot/robotank" directory. After you run those commands then you can copy the install_robotank.sh file into that folder. It's the only file we need to change.
Reply to top
#13
Progress, can now access login page and Robe-Tank GUI,

Have got water level sensor connected and recognised, dc ato pump connected and can run manually but...

pH probe doesn't show up, Temp probe doesn't show up, and all ac outlets can't get working even in manual mode, any clues?

Automatically updated to 6-2 as well

Oh and can't access advanced page for connectors either(maybe connected excuse the pun)
Reply to top
#14
Hmm, this is new. If you haven't unplug power and power back up. Also clear your browser cache, you can press CTRL + F5 a few times in a row.

You should have gotten a popup for the pH circuit, it should ask what it is, click pH and it'll ask for name. When a new temp sensor is plugged in it should ask for a name.
Reply to top
#15
Yep tried powering down and up again, fixed power outlets so I can use them manually but still no pH or temp tried disconnecting and reconnecting them but no joy. Also rules and schedules aren't working either? Database issue?
Reply to top
#16
Interesting, this could be something with database. I didn't actually test the 6.2 install package but thought I packaged the correct database.

Try logging into it using the following.

Add /phpmyadmin/ to your Pi IP address like below.

http://192.168.1.45/phpmyadmin/

Username = root
Password  = robotank

You'll see 4 databases, the first 3 don't mess with, the robotank database is the one.

Expand it, do you see a table called "lightModes", how about "lightModesDetails"?

Click on the "systemSettings" table, you should see one record. Scroll to the right near the end of columns you will see "version" and "versionLatest". Double click each of 6.2 and change to 6.1.  Then power cycle controller, go to settings page in UI and click "Check for Update". It should show one, let it run through and see if that sorts it out.
Reply to top
#17
System settings has nothing in it

localhost/robotank/systemSettings/ http://192.168.1.69/phpmyadmin/sql.php?db=robotank&table=systemSettings&pos=0
Showing rows 0 - 0 (1 total, Query took 0.0010 seconds.)

SELECT * FROM `systemSettings`

sorry does have one row, version 6.1 latest 6.2 can't change the latest though

Got this javascript error whilst in the database as well

"pma_version": "5.0.4deb2",
"browser_name": "SAFARI",
"browser_version": "14.1.2",
"user_os": "Mac",
"server_software": "Apache/2.4.51 (Raspbian)",
"user_agent_string": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.2 Safari/605.1.15",
"locale": "en",
"configuration_storage": "disabled",
"php_version": "7.4.25",
"script_name": "sql.php",
"exception_type": "js",
"exception": {
"mode": "stack",
"name": "TypeError",
"message": "Sql.rearrangeStickyColumns is not a function. (In 'Sql.rearrangeStickyColumns($(t).prev('.sticky_columns'), $(t))', 'Sql.rearrangeStickyColumns' is undefined)",
"stack": [
{
"line": "292",
"func": "",
"context": [
" if (lastException === ex) {",
" processLastException();",
" }",
" }, (stack.incomplete ? 2000 : 0));",
"",
" throw ex; // re-throw to propagate to the top level (and cause wind//...",
" }",
"",
" report.subscribe = subscribe;",
" report.unsubscribe = unsubscribe;",
" return report;"
],
"column": "",
"uri": "js/vendor/tracekit.js?v=5.0.4deb2",
"scriptname": "js/vendor/tracekit.js"
},
{
"func": "dragEnd",
"line": "231",
"column": "43",
"context": [
" }, 'fast')",
" .fadeOut();",
" $(g.cPointer).css('visibility', 'hidden');",
"",
" g.colReorder = false;",
" Sql.rearrangeStickyColumns($(t).prev('.sticky_columns'), $(t));",
" }",
" $(document.body).css('cursor', 'inherit').noSelect(false);",
" },",
"",
" /**"
],
"uri": "js/makegrid.js?v=5.0.4deb2",
"scriptname": "js/makegrid.js"
},
{
"func": "?",
"line": "2256",
"column": "22",
"context": [
" $(document).on('mousemove', function (e) {",
" g.dragMove(e);",
" });",
" $(document).on('mouseup', function (e) {",
" $(g.o).removeClass('turnOffSelect');",
" g.dragEnd(e);",
" });",
" }",
"",
" // some adjustment",
" $(t).removeClass('data');"
],
"uri": "js/makegrid.js?v=5.0.4deb2",
"scriptname": "js/makegrid.js"
},
{
"func": "newFunc",
"line": "267",
"column": "38",
"context": [
" */",
" wrapFunction: function (func) {",
" if (!func.wrapped) {",
" var newFunc = function () {",
" try {",
" return func.apply(this, arguments);",
" } catch (x) {",
" TraceKit.report(x);",
" }",
" };",
" newFunc.wrapped = true;"
],
"uri": "js/error_report.js?v=5.0.4deb2",
"scriptname": "js/error_report.js"
},
{
"func": "dispatch",
"line": "2",
"column": "42942",
"context": [
"/*! jQuery v3.5.1 | © JS Foundation and other contributors | jquery.org/l//...",
"!function(e,t){\"use strict\";\"object\"==typeof module&&\"object\"==typeof modul//...",
""
],
"uri": "js/vendor/jquery/jquery.min.js?v=5.0.4deb2",
"scriptname": "js/vendor/jquery/jquery.min.js"
},
{
"func": "?",
"line": "374",
"column": "24",
"context": [
"$event.dispatch = function( event ){",
"\tif ( $.data( this, \"suppress.\"+ event.type ) - new Date().getTime() > 0 ){",
"\t\t$.removeData( this, \"suppress.\"+ event.type );",
"\t\treturn;",
"\t}",
"\treturn $dispatch.apply( this, arguments );",
"};",
"",
"// event fix hooks for touch events...",
"var touchHooks = ",
"$event.fixHooks.touchstart = "
],
"uri": "js/vendor/jquery/jquery.event.drag-2.2.js?v=5.0.4deb2",
"scriptname": "js/vendor/jquery/jquery.event.drag-2.2.js"
}
],
"incomplete": "false",
"partial": "true",
"uri": "sql.php?pos=0"
}
}
Automatically send report next time
Reply to top
#18
Yikes... I see you're on a Mac, any chance you have a Windows machine to check it? I'm wondering if it's browser incompatibility. Database is probably ok as you have that record.
Reply to top
#19
Maybe I could log in through vnc on raspberry pi?

tried Firefox but wouldn't let me log into oh-admin something about
mysqli::real_connect(): (HY000/1045): Access denied for user 'Root'@'localhost' (using password: YES)
Reply to top
#20
Firefox from Windows? If you can log in via VNC might be worth trying.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  Robotank v6 - can not save any schedule kukulin 5 620 11-07-2021, 09:44 AM
Last Post: Rob F

Forum Jump:

Current time: 05-23-2022, 11:36 AM