Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robo-Tank v5.0 is Ready
#81
Mit dem 3,3v Regler gehts auch nicht
Reply to top
#82
(02-15-2019, 11:12 AM)Rob Wheatley Wrote: Hi Rob
Did put v5.01 on but forgot to do the sd files......
Done now and keyboard is fine.
ATO now appears to be working, the float readout does keep saying open randomly when it is definitely closed (fully submerged)
Going to change to optical sensors soon (can I use optical on ports 1 to 5 as well) and make a combined 24v 240v power bar using one 25 way connecting control cable instead of 2 VGA ones.
Any idea how long the deg C update will take, deg F is confusing lol

Ah so you're viewing the ATO float in one of the boxes on the home screen and you're not referring to the ATO icon below the time?

If so I'm guessing when this happens the pump doesn't actually start up for a quick second nor does the ATO icon turn green?

I think this is just a visual error, on mine I've noticed a couple times a long invalid number on a flow meter where I have to leave the home page and return to clear it all as it prints off the meter. You're likely getting something similar which is why that box changes. It's not serious though as the numbers on the controller are definitely correct, but every so often when the data is coming into the display it gets overridden with new data because it's sent every second. I know what's going on and just have to tweak some things.

It shouldn't be so long for C, I can't believe I screwed that up. :(

I like the idea of a combo AC/DC power bar, might have to copy you one day. :)

You can use optical sensors for the main ATO and the 5 analog ports but you need to change a resistor and add a resistor. I started typing instructions here but instead I'm going to start a new thread showing how to wire those up.

(02-15-2019, 01:20 PM)Addi Wrote: Mit dem 3,3v Regler gehts auch nicht

Well that's disappointing and has me stumped, I'm pounding my head trying to think of why this could be happening. 

One more time, with all your circuits connected, open the serial monitor on the controller, after 20 seconds you'll see the print outs appear in the serial monitor showing 0.0 for all the possible circuits, does that stop or go forever? On the display does the clock change / freeze or does the time keep getting updated?

Does anyone have an Atlas circuit working other than me?
Reply to top
#83
Im seriellen Monitor sehe ich nichts , die uhr auf dem Display zeigt immer wenn die ph sonde einfriert jahr 2009 an , die sonde wird dan über i2c nicht mehr angesprochen, blinkt nicht mehr pro sekunde. Nach neustart läuft es wieder
Reply to top
#84
That says it's hardware related not code and because you see it work a little while shows the code does what it should. The I2C bus is definitely dropping out which is why the clock goes to 2009. I'm curious, what is the length of cable between controller and Atlas circuits? Are your connections soldered or header pin cables?

I know it worked with v4.2 but the problem you have is expected with gen2 hardware but shouldn't be a problem with gen3 because gen3 has an I2C buffer which increases the capacitive load of the I2C bus allowing for longer cable and more devices. When I was using gen2 without the buffer I could only use 1ft of cable between an I2C device and the controller reliably. If I used 6ft of cable it never worked. Overtime I've also noticed different results with gen2 and I2C, for example I've never been able to connect more than 2 devices using 1 cable at 1ft reliably. So the fact some of you could run more is honestly a surprise. Gen2 has nothing special for I2C so it's what the Arduino delivers, I believe the max capactive load for an Arduino is 400pf, any traces, connectors, wire, devices and other factors will add up to a load and it must not exceed this limit. By default there are already 3 devices on the bus, clock, LED driver and eeprom. If the load exceeds the limit the I2C will lock up and at some point it becomes unreliable because it's nearing it's limit and possible other things connected could add noise to the I2C bus causing a surge which knocks it out until the Arduino is reset.

Once I decided to go with I2C power bars this all became very clear to me and I really realized how touchy the I2C bus can be. I search and tried but had lots of problems so I actually hired someone on a website to help me get it worked out. In the end I used the PCA9507 I2C buffer which increases the capactive load to 1800pf from 400pf and has made a world of difference.

Now with all that said I'm not trying to sell you gen3 as it should work again but you might have to change cable length, I'm just trying to explain. Whatever the setup for just the ph circuit is on the edge and why another device knocks it out completely.
Reply to top
#85
(02-15-2019, 11:12 AM)Rob Wheatley Wrote: Going to change to optical sensors soon (can I use optical on ports 1 to 5 as well) 

Here's a link showing how to connect.

https://www.robo-tank.ca/forum/Thread-Co...ter-Sensor
Reply to top
#86
Die kabellänge zur Sonde beträgt bei mir 20 cm , wenn die einzige lösung gen 3 ist ,was kostet mich das ?
Reply to top
#87
Ah this is so crazy, you shouldn't need gen3 as you had it working. I've gone through the code many times to compare with v4.2 and I didn't change anything for how the I2C is setup. Can you do me a favor and try reverting back to v4.2 and verifying they all circuits still work? If so don't breath on anything and try v5.01 again. 20cm of cable should be fine, that's how I have mine setup right now bypassing the buffer so it matches yours and its working ok. I'm going to bang my head some more to see what else I can try.
Reply to top
#88
Hello ,

something happens at the fading to off mode........
When the lights are allmost 10%-15% on and fading, suddenly switch off to to 0%.
Do someone has the same problem?
Rob ?did i sth wrong with the setup?
Reply to top
#89
Sounds like a wiring or settings issue, if you can't find anything with wiring maybe try deleting all the light modes and set them up again in case there is a problem in the code. The code is ok for dimming if settings are ok. Let me know what you try and what works.
Reply to top


Forum Jump:

Current time: 02-18-2019, 06:09 AM