Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robo-Tank v4.0 is Ready
#21
Hi Simone, yeah in the last version I changed almost everything so there could be a few things like this I missed. I thought it was working on 4.0 as I've had my webpage loaded for the last 1-2 months. Do you still have access to the web on v4.0? I just made some changes to how that data goes to the display so I'll send you some updated sketches that should get it working.
Reply to top
#22
Hi Rob, when I try to connect my controller to internet it remains on this screen:


   

After a while it returns to main screen but Internet connections didn't work.. I also search on my router the IP but nothing appears...
Reply to top
#23
Hi Simone, I'm thinking that's happening because it can't connect to your network. The controller uses DHCP to connect, it's possible this option is turned off on your router. If you can log into it and go through the settings you'll probably see an option for connecting using DHCP, my router has this option and needs to be enabled. Here's an image of my setting, its under the "LAN setup" tab on my router. See if you can find something similar.


Attached Files Thumbnail(s)
   
Reply to top
#24
Hi rob, I've checked but as I expected I already have the DHCP enabled from 192.168.1.100 to 192.168.1.199.
wit the "old" 3.6 I can connect to the wep page in a second, maybe should I try to downgrade to 3.6 version to test if all the harware and the connections are ok?
Reply to top
#25
Oh yeah you already said that. Try pressing the "sync" button on the same screen, then when its finished try enabling it again. I'll be sending some updated sketches later tonight so don't bother with 3.6 yet.
Reply to top
#26
I try the Sync System button then I try to enable internet connection again but nothing change... I'll wait your sketches ;) thank you again Rob!
Reply to top
#27
DHCP Should be set to 254 as last digit set, otherwise you’re not using the full range

Don’t know if it would fix the problem, but your router isn’t using the full range of IP adresses available in your subnet
Reply to top
#28
Hi, I update to the new 4.05 but nothing change, I also tested my Ethernet Shield and RJ45 cable with the simple WebServer for Arduino UNO and it works perfect. Can I do the same test with Arduino DUE and Robotank board?
Reply to top
#29
hmmm, that doesn't make any sense, you can upload a test sketch to the controller Arduino and test on the board.

Another thing to try, open the serial monitor in the Arduino IDE for the controller Due. You should see the following.

Initializing sd card...
SUCCESS - sd card initialized.
SUCCESS - Found index.htm file.
eepromValue: 50
Starting Controller -------------------65
Startup Complete -------------------9416
Startup Complete -------------------9619

Then enable the internet and you should get the following except with valid info beside each line.

Connecting to Network -------------------29431
Alert To Email Address: 
Alert From Email Address: 
smtp2go Username For Alerts:
smtp2go Password For Alerts:
Connecting to Router
Connected to Router Successfully
Web Access Username: 
Web Access Password: 
My Local IP address: 
My External IP Address: 
Connected to Network -------------------36535
Reply to top


Possibly Related Threads...
Thread Author Replies Views Last Post
  Robo-Tank v5.20 is Ready Rob F 41 1,455 8 hours ago
Last Post: Rob F
  Robo-Tank ATO System - Standalone Product Rob F 15 116 Yesterday, 06:38 PM
Last Post: Rob F
  Robo-Tank Hardware Expansions Coming Soon Rob F 6 240 09-04-2019, 06:25 AM
Last Post: Rob F
  Robo-Tank v5.13 is Ready Rob F 61 2,922 06-19-2019, 12:30 AM
Last Post: Rob F

Forum Jump:

Current time: 10-13-2019, 11:29 PM