Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Robo-Tank v2.0 is Ready
#1
Hi, so I finally have the update finished, lots has been changed and optimized to get the sensor and parameter rules working and now you can do almost anything with the equipment. Things that can't be done will be added so they can be done. Big thanks to Chris and Dom for helping test some things out.

I also included logging and graphs for the 12 main water parameters, it just came to my attention some of the graphs are out of range for sea water so that will be updated shortly.

Here's a list of the changes, there's probably more but these are the main ones.

Please post any errors if you find them so I can fix them and if you can think of more features please post them here so they can be considered and not forgotten.

Additions

  • Parameter and Sensor Rules for Controlling Equipment
  • Expansion Hub Works With Optical Sensors, Float Switches, any Digital or Analog Sensor and 2 Additional Water Pumps
  • Data Logging and Graphs for Water Temp, Light Temp, Temp 1, Temp 2, PH, ORP, Dissolved Oxygen, Saturation, Conductivity, TDS, Salinity, Specific Gravity)
  • Assign Expansion Ports
  • Test Mode For Lighting Schedules (run through 24hr cycle in 1 minute)
  • Added ATO Safety Features
  • Added ATO Status Icon
  • Added Web Connection Status Icon
  • 24 New Email Alerts

Improvements

  • AC Power outlets are now off when controller restarts and resume to proper state
  • Re-programmed dosing pumps for better efficiency and ability to handle 250 doses per reservoir
  • Optimized communications between modules
  • Improved touch screen response
  • Improved slider response time
  • Controller can use the accurate DS3231 RTC clock
  • AC power outlets have indepenant manual mode, when an outlets state is manually changed nothing can change the state of that outlet until the resume button on the home page or webpage is pressed.
  • Changed web alerts from twitter RSS feed to email
  • Resume button on home page has 3 functions, if pressed momentariliy AC outlets in manual mode return to auto mode, when pressed and held for 1 second controller beeps and lights resume to current light mode according to the daily schedule. When pressed and held for 5 seconds the controller beeps twice and a hard reset is done on lights and outlets
  • Optimized display code increasing space for more features
  • Expansion Hub W5100 Ethernet Shield can now use Fat32 microSD card

Fixes

  • Fixed lightning fade on channel 7
  • Fixed fade at start of storm, it went to the cloud target immediately the first time after restarting power bar
  • Fixed scheduling conflicts, if all schedules where set to midnight some won't go off
  • Fixed network information displayed in settings
  • Fixed multiple minor user interface issues
Reply to top
#2
Hi Rob

very good K05164 K05164

Thanks
Reply to top
#3
Well Done
Reply to top
#4
Rob, 

Just got my boards back today. Loaded up the test sketches and everything seemed to be working. Saw the update and decided to download and install that instead of v1.6. 

Are we still using Arduino IDE 1.6.0 to upload sketches? If so getting the below errors when I compile the Display sketch:
Code:
Arduino: 1.6.0 (Windows 8), Board: "Arduino Due (Programming Port)"

Build options changed, rebuilding all

DISPLAY_RoboTank_V2.ino:55:1: error: 'Scheduler' does not name a type

DISPLAY_RoboTank_V2.ino: In function 'void setup()':

DISPLAY_RoboTank_V2.ino:1011:1: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino: In function 'void loop()':

DISPLAY_RoboTank_V2.ino:1031:1: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino: In function 'void writeGr()':

DISPLAY_RoboTank_V2.ino:22279:21: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino:22280:38: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino:22281:6: error: 'scheduler' was not declared in this scope

Error compiling.

 This report would have more information with
 "Show verbose output during compilation"
 enabled in File > Preferences.

Both the Power Bar and Expansion sketch compile and upload with no errors. Haven't really dug into it yet to troubleshoot, but just wanted to let you know. 

This was all done on a fresh install of Arduino 1.6.0 and all new libraries from the V2 download.
Reply to top
#5
Thanks guys.

Hi zfreak_1125, yes still using IDE 1.6.0, it looks like you are missing the "Scheduler" library. In the libraries folder you'll see a folder named "Scheduler" make sure you move it to your "documents/arduino/libraries/" folder. Then restart the IDE and it should compile.
Reply to top
#6
Rob,

Wasn't thinking late last night when I was trying to set everything up...only copied libraries into the IDE install directory. Copied them into sketchbook and everything works like a charm. Got ports forwarded and connected right up.

Thanks for all the help.

Matt
Reply to top
#7
Great, glad to hear you got it going.
Reply to top
#8
Hi Rob
I use Arduino IDE 1.6.0 to upload sketches. I get the errors when verify the Display sketch:

Arduino: 1.6.0 (Windows 7), Board: "Arduino Due (Programming Port)"

DISPLAY_RoboTank_V2.ino:88:1: error: 'Scheduler' does not name a type

DISPLAY_RoboTank_V2.ino: In function 'void setup()':

DISPLAY_RoboTank_V2.ino:1044:1: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino: In function 'void loop()':

DISPLAY_RoboTank_V2.ino:1064:1: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino: In function 'void writeGr()':

DISPLAY_RoboTank_V2.ino:22312:21: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino:22313:38: error: 'scheduler' was not declared in this scope

DISPLAY_RoboTank_V2.ino:22314:6: error: 'scheduler' was not declared in this scope

Error compiling.

This report would have more information with
"Show verbose output during compilation"
enabled in File > Preferences.

Both the Power Bar and Expansion sketch compile and upload with no errors.
All libraries folder moved as per your instruction (including "Scheduler") to" ...documents/arduino/liberaries/".

Thanks
Reply to top
#9
Hi Vilich, it's not seeing that Scheduler library, this is the only reason for that error. In the Arduino IDE, click File, Examples and see if Scheduler is in the list. Maybe try restarting the computer, I know I've closed my IDE but it didn't close, it was still open in the task manager. If you know how to view the task manager you can end the proccess for arduino there and then restart it. If not restarting the computer will do it.
Reply to top
#10
Hi Rob
Display sketch compile and upload with no errors.
I reinstalled arduino software.

Thanks a lot
Reply to top
#11
Hi Vilich, glad to hear you got it working.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  What the heck is going on with Robo-Tank? Rob F 0 100 02-11-2020, 10:50 AM
Last Post: Rob F
  Robo-Tank ATO System - Standalone Product Rob F 25 1,024 12-28-2019, 01:39 PM
Last Post: Rob F
  Robo-Tank Hardware Expansions Coming Soon Rob F 13 796 11-10-2019, 01:36 PM
Last Post: Rob F
  Robo-Tank v5.20 is Ready Rob F 41 2,962 10-13-2019, 03:03 PM
Last Post: Rob F

Forum Jump:

Current time: 02-24-2020, 11:33 PM