Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lighting problems
#1
So I’m still running 5.13 but starting to notice a pattern...
Every time one of my scheduled dosing containers run low or empty the lighting screws up.
Sometimes is doesn’t come on, sometimes it gets stuck in a mode and sometimes it doesn’t respond at all.
Today I had a new and more interesting one..
The PWM got inverted, so with the slides moving to 0 the lights got brighter.
Normally to fix this I just save the time and date and everything is working again.
Today that didn’t do the trick, I had to power down everything for 5 minutes to get it sorted.

Everything is back to normal for now but it’s starting to get annoying.
Reply to top
#2
Don't let the dosing container run low and problem solved lol, just kidding of course.

You brought this up at a good time, with the help from a customer we discovered a pretty big overlook on my behalf.

Remember when I first released v5.0 many had issues with I2C going down, the likely reason for all these issues was in the lighting code.

When a fade runs the controller was sending an update to the PCA9685 PWM chip about 1500 times per second or more which flooded the I2C bus with data, frankly it's amazing it works at all.

I completely over looked this as the fade code was the same as v4.2 but the difference was v5.0 runs so much faster than v4.2. v4.2 couldn't run fast enough to flood the bus.

I will have an update ready soon which has a lot of small issues fixed but will email the current sketches now.
Reply to top
#3
Got your email, for now I’m good for the coming 3 weeks since I refilled the dosing constrainers yesterday.
Updating will take some time since I’m busy preparing my house for a PV system and a remodel of the kitchen and bathroom XD
But the I2C problem was already evident in the v5.0 and with v5.13 i got over 20K cycles a second so it kinda figures it would screw up something somewhere.
But good thing you’re working on it and identified the cause of the problem ;)
Reply to top
#4
Sounds good, I'm amazed the I2C can handle that many writes per second however that number will drop some depending how many channels are enabled when the fade is running as there's lots of math involved. Bad news for you though, with coming update it won't be 20K as disabling the stuff not being used will only hide things on display but they will still run on controller. Had to do this for now as I'm activating all the addons and it's just easier for now. The following update will have it back to 20K. :)

Always doing something with it, this update has a lot of little issues and some bigger fixed, it's a definitely must update.
Reply to top
#5
You mean 5.21 or the one you sent me?
Reply to top
#6
Yes 5.21 not what I sent.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  having problems updating brfreeman7 30 1,381 04-23-2019, 10:39 PM
Last Post: fietsenrex

Forum Jump:

Current time: 11-21-2019, 09:01 AM