Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Hardware ports
#1
Hi Rob,
first of all I'm very happy with the new look of the v 5.00!!!
I'm trying to connect my hardware to my REV-E board following the "Robo-Tank Gen2 Connecting the Equipment.pdf" file.
I think that there's something wrong (or that I'm doing wrong)
To test it I connect a DHT22 to Plug 7 on the pin labeled as "Light" which should be Port 9. I set the type sensor on Port 9 to DHT22 but on the main screen and even in the Sensors tab I couldn't see anything.
If I set it to Port 11 (even if it connect to port 9) it now works on the main page but not on the Sensor reading tab.

Another strange thing is that the keyboard to customize the labels didn't show on the screen but this is regarding the software...

Thank you vvery much!

Simone
Reply to top
#2
Hi Simone, glad to hear you got it installed, did you have any trouble with the install?

I looked into the missing keyboard, this was an image I forgot to copy over. You also didn't see the splash screen when display turns on for the same reason. For today copy all the images from v4.2 back to your display SD card in case there's a couple others I forgot, I'll have to go through it to make sure I got them all.

For the port not working this is something I forgot to mention. I didn't setup the controller to cover all the ports on Gen 2 hardware, now Gen2 becomes Gen3 basically. This means you won't have access to all 7 temp sensor ports, now you can only use 5 of them. The last two you can't, "temp3 and temp4". You also will lose access to the last 2 flow meter ports and the last 4 dosing pumps.

It's possible you will gain access again to those ports but I just had too much to track without trying to make the software cover two board types. I hope this isn't a big problem for you.

The Sensor parameter page currently isn't working, will be soon. All you will get is a bunch of empty boxes.
Reply to top
#3
Hi Rob, no trouble with the install, the only thing I didn’t find the folder for the weather setup...
No problem for the number of sensors, there are plenty of them :D I only have to know which physical port or pin correspond to the ones on the program...
Reply to top
#4
There is no folder for weather, you just need to add your OpenWeather API key code in the controller sketch. For the email alerts you enter the data on the system settings page. I forgot the API key that's why it's not there but will be later.

For the port numbers you can get it from the new faceplate. Here's a link. For everything start with the first port on your controller and it'll be the same as the first port for same type on faceplate. For example water temp is the first temp port on Gen 2, that would be "temp 1 / port 9" in the software.

https://www.robo-tank.ca/forum/Thread-Co...-Faceplate
Reply to top


Forum Jump:

Current time: 02-18-2019, 06:18 AM