Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Expansion Hub Connection
#1
Rob,

Question regarding connection to the expansion hub. Will the hub connect to the display/power board if it fails to get an IP address from the router?  Have a situation where my expansion hub isn't connecting to the rest of the controller and am trying to see where it might be hanging up. Everything was working perfectly for the past 5 months.

I've already tried a complete reboot of the controller by unplugging it and still not working. The display and power bar connect and everything there is working. I'm not there to troubleshoot in person so I'm trying to talk someone through what to do.  Unable to have them connect to the serial port on the second Due as they can't easily access the port. 

I'm going to try to have them login to the router to see what devices are connected, but that won't be until later. Any other thoughts...need to try to figure this out as the expansion controls the ATO and RO unit for the tank. Thanks

Matt
Reply to top
#2
Hi Matt, sorry to hear about the troubles. If the expansion hub isn't plugged into the router or can't connect to the router it will hang during startup for about 5 minutes as its trying to connect. The expansion hub checks for a valid internet connection every couple hours and tries to re-connect, it will hang here as well but only a minute or two. Then it should work fine until it checks for the internet again. If someone can plug the expansion hub into the computer and open the serial window there are details shown as it starts up. Maybe something happened on the SD card and the login files got corrupted so no username or password for the internet.

If the expansion hub doesn't connect to the internet it should still work however the display globe icon under the time won't be green, its actually based off being connected to the internet and not the controller. So its possible the icon be grey but expansion hub still communicating properly. To find out press the "service" button on home page to see if it loads, if it loads the expansion hub is working.

If possible the expansion hub can be unplugged and tested on the computer. Plug in the internet, power it up and connect to computer and see what the serial window says.
Reply to top
#3
Got it fixed. Needed to open the controller case (forgot to add an access port to the reset button...doh!) and do a manual reset on the ethernet Due/expansion board while the controller was powered on, and then everything started working.

First mod as soon as I get back is an access hole to that reset :)

Thanks again Rob.
Reply to top
#4
Good to hear. How did all this happen, did the controller just quit working or was it unplugged for a while? I just discovered the other day I have some Arduino Due's that require a firmware update, apparently some of them require this and it's possible yours does too. With these Due's if they've been powered off for 5-10 minutes or more they require a reset to startup properly. I just found out so haven't updated any yet but someone has with no issue and it solved the problem. I'm going to post a step by step showing how to do this, it requires a Mega 2560 to update it. If that's not possible it can also be solved by soldering a resistor to the Arduino.
Reply to top
#5
Not 100% sure what happened, but the house lost power during a storm for a little while and I think that's when the problem started. Up until that everything was working properly. There's was one other time that it stopped connecting, but simply powering the whole controller down and restarting it fixed it that time.

So it sounds like the Due on the expansion hub could need a firmware update, as the reset fixed the connection issue. I'll look for the instructions and add that to the list of other tank improvements I'm gonna make when I get home.

Thanks again for the help.
Reply to top


Possibly Related Threads…
Thread Author Replies Views Last Post
  Power connection display boards Arne 1 1,941 09-13-2016, 03:39 PM
Last Post: Rob F
  Video - Connecting Expansion Hub To Controller For The First Time Rob F 0 4,566 03-01-2016, 04:30 PM
Last Post: Rob F
  Web Access Connection Issue Tupac 50 18,440 02-22-2016, 02:04 PM
Last Post: rott

Forum Jump:

Current time: 11-26-2020, 11:51 AM