Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
E-mail setup
#1
Hi rob,
I'm trying to configure the emil alert function. I've created a new account on SMTP2GO as you've described. Then I entered the username and password in the System Settings page on the controller.
I then create a simple alert for a temp >=25 on a sensor with email alert and a beep every 10s. If I increase the temp of the sensor the beep starts but the email doesn't arrive (even the log file doesn't take care of the alert)
Am I doing something wrong? the controller is online and I can reach the webpage form my browser.
Thank you very much!

Simone
Reply to top
#2
Hi Simone, it sounds like the alert is working, when it's triggered that isn't logged but maybe it should be. I think I'll have to make just an alert log. Is the From and To email address the same? If so maybe try setting up a different email for it using hotmail or gmail. It could be just the provider for the current email that is blocking it.
Reply to top
#3
Hi Rob, yes the alert works properly... I'm testing with two different emails that I have, one is Gmail.com and the other Hotmail.it... I tried to swap them between from email and to email but nothing change... Do I have to insert anywhere the password of the sender email? even in SMTP2GO?
Thank you again...
Simone
Reply to top
#4
Hi Simone, there is no passwords required for the emails anywhere but I think I remember a problem with Gmail accounts for sending and just found this on SMTP2GO website.

Quote:
  • If you're sending from a free email service such as Hotmail, Yahoo, etc. your emails are often treated more suspiciously by recipient spam filters. It is always better - and more professional - to send emails from your own (or your business') domain name. You should never send emails from a Yahoo or AOL email address (as of April 2014) as these domains are now restricted by their DMARC policies. You should also not send from a Gmail email address as of June 2016 due to Gmail's new DMARC policy.

Maybe the same applies to hotmail.it accounts. For mine I use my Robo-Tank email to send and hotmail account to receive, I just flipped them and hotmail had no issues sending but I'm using .com so maybe that's the difference. Is it possible to open a hotmail.com account? Also when you go into your SMTP2GO account, on the dashboard at top it shows a bounce rate and spam rate, are those showing anything?
Reply to top
#5
Hi rob, thank you for your answer, I'll try with hotmail.com and let you know..

P.S. Bounce rate and Spam rate doesn't show anything...

I think I foud the problem.. SMTP2GO ask me to create a Sender Domains before I can send any email.. do you know how can I do that?
Reply to top
#6
One thing I forgot to mention, beside the bounce and spam it shows how many messages out of the 1000 allowed for month was sent, is this showing anything or 0?

I looked at the sender domains, that's a newer feature but doesn't apply. It's only an option if you have your own domain name or website address. I'm using my own domain but don't require that as I get every email. On the SMPT2GO website go to the "users" menu and verify you see the username and is exactly how it's in the controller.
Reply to top
#7
Hi rob, yes users and password correspond...


[Image: b132ea23dc330197d9dada5afcf256d5-full.jpg] upload
Reply to top
#8
Ah wow, that's interesting, I've never seen that. I thought maybe you emailed them. Can you click on settings, users and under your username does it show the following?

Connecting via SMTP
SMTP Server: mail.smtp2go.com

SMTP Port: 2525
Alternative ports: 8025, 587, 80 or 25. TLS is available on the same ports.

SSL is available on ports 465, 8465 and 443.
Reply to top
#9
Yes under the user I have all of these settings...

[Image: fa812deb2d6809d62c9383079f27b476-full.jpg] upload

Maybe I can contact the support?

So, I've contact the SMTP2GO support, they have to unlock your account... After that it works!! :)
Reply to top
#10
I've been going through everything but not sure what to suggest. As far as I can tell the sender domain is only for your own and for some reason it seems necessary, I hope that's not a new requirement for new signups. You might have to contact them to see what they say, tell them you don't have your own domain and trying to use hotmail/gmail. This is definitely the issue though as it says 0/0 emails so it's not allowing any to go through.

EDIT: Maybe try adding a sender domain, use gmail.com to see what it does. Forgot it, just tried but it says not allowed.

I just found this quote in their support info which implies you don't need a sender domain.

Quote:If you don't set up a sender domain, SMTP2GO signs all emails with our own DKIM signature. This means that some recipients will see emails as being delivered "via smtpcorp.com" or "via smtp2go.com".
Reply to top
#11
Oh wow, they are very quick! Glad to hear its working, hopefully it solves that other issues with disconnection.
Reply to top
#12
Yes they were very quick! Anyway I think that the unlock procedure must be done by them... I hope that these will solve the other problem, I’ll let the controller on over night and I see how it goes... thank tou very much!!:)
Reply to top
#13
No problem, let me know how it goes.
Reply to top
#14
Hi Rob,
Again this morning I found it locked with the red icon at the top right...
Reply to top
#15
Hi Simone, I should have mentioned this yesterday, can you go to system, settings and press and hold restore defaults button. When updating from 4.2 there was some issues and the restore typically fixed it.
Reply to top
#16
Hi rob, I try the restore defaults button but it locks again... May it be something related to the network connection? thank you again...
Reply to top
#17
It could be network related but I would have thought it would time out instead of keeping controller locked. Am I correct that you are just using the web features for the first time, never used in v4.2? If so can you try disabling the web on the settings, system page at the bottom. Then let it run to see if it still locks up.

One thing to note, the web setting will show it's disabled even though it's not, press it a few times to cycle it so you know you have it set correct, then restart the controller and the globe under time shouldn't be green.
Reply to top
#18
Hi rob, yes I’ve never use web feature before... now I’ve completely disabled web features and disconnect the network cable. How can I solve the timeout problem? On my router I’ve also tryed to reserve a static IP to the controller mac address... thank you again...
Reply to top
#19
Hi Simone, I'm not completely sure its the network causing the problem, let it run a few days and if it doesn't lock up it's likely related and we will go from there. When you ready to try the network again, enable it, restart the controller and mark down the time you did that to second and if it locks mark the time the clock freezes at, maybe this will tell me something. I'm wondering if it's locking in an hour or a day or random.
Reply to top
#20
Hi Rob, after a few days it never "locks" again (by lock I mean the lost of connection between the display and the Controller). So I can think that is all related to the network...
Should I reconnect the network? There's a way to know when it lost the communication?
Another simply question, can I use a Keystone RJ45 plug to extend the cat5 cable to the display? Or it can cause some problem to the data communication?
Thank you very much

Simone
Reply to top


Forum Jump:

Current time: 06-24-2019, 01:22 PM