Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ATO Not Working As Expected
#21
I replaced the microSD card with another one that I have. It was weird, the rules were still there... I deleted them and added them back. We'll see if this fixes it. One note: When I added them back I checked the option to send an email with both rules but then it wouldn't work. I removed that and added them back without the email notification and it works.

So I restarted the controller this morning by saving the time and the ATO rules don't work again. I removed them and added them back and it's ok. It's almost every time I restart the controller. I have restarted it several times before with it breaking though...
Reply to top
#22
As I mentioned in the other thread I think it's all SD card related. The rules work when you add them because doing that fills all the variables in the code but once you restart controller those variables are wiped and because it's not reading the SD card those variables aren't filled again so the rules won't work.

For the email alert in rule that could be code, I'm going to do some tests soon with a bunch of scenarios to see if that could be code, I'll let you know.
Reply to top
#23
Thank you!
Reply to top
#24
I ran into an issue where the ATO started and didn't turn off again. I was drip acclimating some new fish and probably took out around two gallons of water this way. The next time the ATO turned on I knew that it was going to be on more than usual to make up for the additional water that was removed. After dinner it was still going so I went to check on it and it didn't turn off when I raised the float switch. I'm attaching the most recent few pages of the log as pictures - it's easier than taking the SD card up to the computer. I started the drip acclimation around 445 or so.

I forgot to mention that I just hit resume and the ATO pump turned off.


Attached Files Thumbnail(s)
                           
Reply to top
#25
Hi aquaalgae, sorry to hear, I'm guessing when you pressed resume at 6:32:50 is when you turned off outlet 4? Pressing resume button would turn outlet 4 off because there are no schedules set so default is off, resume puts everything in default based on schedules and because the ATO wasn't setup for outlets it will still do that. The thing that confuses me is about 2 minutes later it says ATO finished running. You mentioned you raised the float to see if it would shut off, was that before the ATO was actually supposed to be finished? I ask because if so that would make sense why the ATO max run time didn't shut it off. Because the top off was larger than normal it should have timed out before finishing if you have that set to the say 11 minutes. I'm guessing 11 minutes because I see earlier it ran for about 10 minutes which I'm guessing is normal run time? If you removed 15 minutes of water it should have never filled up. What do you have the max ATO run time set to?
Reply to top
#26
Rob,

I'm having a new issue with the ATO. For the past week, i have had the ATO time out more often - sometimes every day. I have the limit set to 15 minutes.

I was away this past weekend and it happened shortly after I left on Friday morning. I have a camera set up to look at the sump so I can see how low it is while I'm away. I was manually turning on the relay to add water but the water level never came up. Unfortunately the camera wasn't positioned to see the ATO water come out of the tube.

When I got home yesterday I turned the relay for my ATO pump on manually. I heard the relay click but the pump didn't turn on. I tried again and again. It clicked each time but the pump didn't turn on. I tried restarting the controller by saving the time and I was still having the same issue. At this point I though somehow the pump was dead, but when I plugged it into the wall it worked fine. Next I manually started all relays and the manually stopped all relays and then clicked resume. This time it worked correctly. I continued to test it by turning the relay on and off manually but about 20% of the time it didn't actually turn the pump on.

Could this be a software issue or is the relay going bad?
Reply to top
#27
Hi aquaalgae, I'm afraid the relay is going bad which you could probably verify with an AC volt meter. Put the probes in the outlet and see what voltage you get when it turns on/off. It's probably not always letting the full power through. Back in the day I use to work on two-way radios and one had a relay and this was a frequent problem. With those the lid could come off and after cleaning between the leafs it's was like new again. Obviously it's clicking ok so probably dirty contacts internally. I'll be happy to get away from these type, sorry but still probably a month away till the solid state one is ready.
Reply to top
#28
What can I do to fix it? Can it be easily replaced?
Reply to top
#29
Unfortunately it's a big job working on the power bar, you would have to desolder all outlets and switches to remove the PCB. Sadly I think you'll be short one outlet.
Reply to top


Forum Jump:

Current time: 02-18-2019, 06:15 AM